# 安装

提示

目前 Flutter SDK 尚不支持空安全。

# 安装 Flutter 插件

CloudBase Flutter SDK 提供一系列插件,可以根据场景按需安装。

Plugin Version 文档 描述
cloudbase_core (opens new window) pub package CloudBase Core 核心库,初始化环境等
cloudbase_auth (opens new window) pub package CloudBase Auth 鉴权库,支持微信登录、自定义登录、匿名登录等
cloudbase_function (opens new window) pub package CloudBase Function 支持云函数能力
cloudbase_storage (opens new window) pub package CloudBase Storage 支持对象存储能力
cloudbase_database (opens new window) pub package CloudBase Database 支持文档型数据库能力

# 示例代码

在 flutter 项目的 pubspec.yaml 文件的 dependencies 中添加需要的插件,例如:

dependencies:
  cloudbase_core: ^0.0.9
  cloudbase_auth: ^0.0.11
  cloudbase_function: ^0.0.2
  cloudbase_storage: ^0.0.3
  cloudbase_database: ^0.0.10